Site Login

This Months Donations

$251.81
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Hunter W
$5.00
antwon87
$5.00
Adityavikram Rajawat
$5.00
Adityavikram Rajawat
$5.00
Sebastian Sott
$2.00
Number of donations
48
Highest donation
$50.00
Average donation
$5.33

InputMapper 1.7 Alpha available for testing

1 year 11 months ago #1 by Wobbles
There are several known issues and shortcommings;

Application will NOT...

InputMapper 1.7 alpha is available for testing.


There are several known issues and shortcommings;

 

  • Application will NOT update or notify of updates until released live (You must periodically check back in this article or forum for updated copies while in alpha/beta state)
  • Macros not finialized, if macros are important to you perhaps hold off a bit
  • Though all mappings are accessible, the mapping UI is still hackish/incomplete
  • Installer will NOT install 3rd party drivers needed for many features (This will be implemented once the drivers themselves become more stable)
    Do NOT install drivers that you do not NEED.
  • Behavior is untested and could be problematic if installing next to existing copies of IM
  • (NEW) Icon font will not properly replace old font if you currently have IM 1.6 installed. Delete InputMapperIcons.ttf from your fonts folder prior to install IM 1.7 to fix this
  • (Enhancement) Color wheel, RGB value, HSC, need to be added to lightbar to make color picking easier.
  • (Enhancement) Values for sliders in axis tuning
  • More to come as discovered...

Download HERE: https://InputMapper.com/attachments/InputMapper (1.7.6239.21119).exe

Read article...

Please Log in or Create an account to join the conversation.

1 year 11 months ago - 1 year 11 months ago #2 by César Navarro
Maybe you already know of this bugs but as i'll found them i'll list them here:
- Found graphical bug, the lightbar edit button appear as delete button also there's no way to delete a lightbar profile. (found a fix)
- Virtual X360 controller appear in windows controllers without any physical controller pluged in.
- Graphical bug not showing x360 icon. (found a fix)
- Exclusive mod don't hide the HID device.
- No option to take device exclusively nor interface that shows that is in exclusive or shared mode.
- There's no option to show log anymore. (planned?)
- Virtual controller appear in input mapper as a physical controller. Also if you select for example the same profile in that virtual controller as in the physical one more virtual controllers for the virtual ones will appear.
- If exclusive mode triangle is clicked a new virtual controller will appear (up to the 4 virtual with only 1 ds4 physical)

Font Fix:
For the font as Wobbles said just uninstall the old version of inputmapper so the new one could take place. that fixed most of graphical bugs for me.

Please Log in or Create an account to join the conversation.

1 year 11 months ago - 1 year 11 months ago #3 by Maxwellru
also ds3 icon is wrong. It shows ds4 icon with dongle.

can you add some presets for lightbar? like it was in 1.6.10

and would be nice to see [AutoSence] profile setting :)

Please Log in or Create an account to join the conversation.

1 year 11 months ago #4 by Wobbles
I think I included the wrong version of the font library and thats why the icons may be messed up lol.

Please Log in or Create an account to join the conversation.

1 year 11 months ago #5 by Wobbles

Cesar Navarro wrote: Maybe you already know of this bugs but as i'll found them i'll list them here:
- Found graphical bug, the lightbar edit button appear as delete button also there's no way to delete a lightbar profile.
- Virtual X360 controller without any controller pluged in.


Icons are bad because I included wrong version of font.

Deleting light bar profile; yea only way is to delete the file right now, will fix

Can you explain the controller issue more?

Please Log in or Create an account to join the conversation.

1 year 11 months ago #6 by César Navarro
when i was changing the output driver to test them, when i selected "vigem360" and then back to scp appear 2 virtual controllers, 1 for the actual ds4 controller and one "extra" that was a ghost, when i unplugged the ds4 controller both x360 virtual controllers kept plugged in. i just closed the program and re-opened then was only 1 controller showing, btw i wanna know is normal that the virtual x360 controller appear as a plugged in controller in input mapper?

Please Log in or Create an account to join the conversation.

1 year 11 months ago #7 by Wobbles
IM now supports 360 controllers so yes, but the controller remaining on switching is not normal so ill take a look.

As to the Icons, I actually didnt include the wrong font, but if you had an old version of IM installed you may need to remove the old font so the new one installs properly

Please Log in or Create an account to join the conversation.

1 year 11 months ago #8 by César Navarro
I know that support more controllers but the virtual ones should be somehow exclude from showing also look at what i edited above. will keep searching for bugs.

Please Log in or Create an account to join the conversation.

1 year 11 months ago #9 by Wobbles

Cesar Navarro wrote: I know that support more controllers but the virtual ones should be somehow exclude from showing also look at what i edited above. will keep searching for bugs.


Easier said than done, the whole reason IM works is because applications cannot tell the difference between a virtual and a physical controller.

Please Log in or Create an account to join the conversation.

1 year 11 months ago - 1 year 11 months ago #10 by César Navarro
Well that's true i'm not a coder, btw i'm having a lot of duplicated devices with the nefarius new drivers + scp drivers, can you tell us the right installation steps to not mess up everything? also i can't enable the exclusive mode the triangle does nothing.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum