Site Login

This Months Donations

$545.03
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
SiesMAN01
$2.00
André Philipi da Silva
$2.00
lookingglassties
$2.00
Keanu Allridge
$5.00
Sven Eckelmann
$10.00
Number of donations
25
Highest donation
$500.00
Average donation
$21.92

Check In: Jan 16 2018 (How to DL and use IM 1.7 nightly build)

1 year 9 months ago #1 by Wobbles
...

Please Log in or Create an account to join the conversation.

1 year 8 months ago #2 by wirenut48
Question, I still having problems running these nightly builds, but at lease now know how to do it correctly. Will this work using a controller connected thru BT? I can't get IM to recognize my controller, and no output driver options show up in the dropdown. Have vigem 1.5.2.0 installed + HIDguardian here from the download section.Tried using the sony dongle but can't get the controller to list in the joy.cpl. Would like to play around with these builds but not having any luck getting anything to work. All works okay with the executable alpha 1.7.6317.17167 and 1.6.10 using the SCP driver, both in exclusive mode thru BT.

Just tried using the controller with USB, still won't show up in the nightly build. Guess I'm going to have to figure out why the Sony dongle is not working.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 8 months ago - 1 year 8 months ago #3 by wirenut48
Just a bit of more info after playing around some. I have to 2nd gen controllers, only one was detectable with the older 1.7. So I tried that one on the nightly build, didn't work, but now it won't show up on the older build anymore. What a mess, now all I have is 1.6 working.

EDIT: maybe I need to uninstall the older version of 1.7 to get the nightly ones to work.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 8 months ago #4 by Wobbles
Nightly builds require vigem 1.14 as of the last couple. Remove the old drivers then use powershell and the commands in nefariouses wiki to install the new ones github.com/nefarius/ViGEm/wiki/Driver-Installation

Please Log in or Create an account to join the conversation.

1 year 8 months ago #5 by Wobbles
Also, IM 1.7 has never used anything less than ViGEm 1.8, so you likely have been having issues because of using an old version.

Please Log in or Create an account to join the conversation.

1 year 8 months ago #6 by Chris
seems the nightly don't work for me...yyyyyyy
after deleting old drivers and installing the new one via powershell and starting to run the nightly build i get:

Base: ERROR
Unhandled Exception

attached the debug log
Attachments:
The following user(s) said Thank You: Kenichi

Please Log in or Create an account to join the conversation.

1 year 8 months ago #7 by wirenut48
I do have that latest version 1.14 installed, I got that ver # above straight from the .sys driver properties. Believe that my problem is trying to run 2 different ver of 1.7 that require different versions of the driver. Anyway I'm primarily sticking to 1.6 until we get macro support for 1.7.

Might uninstall the old version of 1.7 so I can play around with the nightly builds.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 8 months ago #8 by Wobbles
Yea, the ViGEm version change is definitely a change from last couple releases. 1.6 and 1.7 with ViGEm 1.14 should be able to work side by side for testing purposes.

Please Log in or Create an account to join the conversation.

1 year 8 months ago #9 by wirenut48
Uninstalled the early 1.7 alpha, and ViGEm driver. Reinstalled IM 1.6, HIDGuardian, and ViGEm then ran the nightly build. Still won't recognize any controllers or show any driver options in the profile dropdown list. I'm done fooling with it, but will attach debug log if you want to take a look at it.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10
Attachments:

Please Log in or Create an account to join the conversation.

1 year 8 months ago #10 by Wobbles
Your log shows you have some extra files in the plugins folder, may need to delete the folder and replace it fresh, could be loading things it shouldent be.
The following user(s) said Thank You: Chris

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum