Site Login

This Months Donations

$117.23
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Yoshihisa
$5.00
James
$2.00
Boss
$2.00
Stephen Brent Penados
$2.00
Arrafi
$20.00
Number of donations
23
Highest donation
$20.00
Average donation
$4.64

Controller inputs 'sticking' in wow

7 months 5 days ago #1 by Raddan
InputMapper Version: 1.6.10.19991
HidGuardian (1.0.6230.17641)
Windows build 1809 (also happens on previous builds)
1st and 2nd gen controllers on both BT and USB
Exclusive mode true (also happens when false)

This seems to only happen when playing World of Warcraft, I use the left joystick for my movements which I have assigned to the arrow keys currently but I also get this issue when using wasd as well. What happens is I'll make a movment, but the direction will stick even though the joystick is neutral. The only way to unstick it is to press that direction again on the joystick. I have reinstalled inputmapper and all associated software and it has also followed me though a motherboard upgrade and fresh windows installs. The frequency of this issue seems to be random, happening ~ 15mins apart depending on activity, but it might be linked to multiple inputs. Reason being is that I notice it most when I'm in combat vs just running around. I'll post logs once I generate some as it looks like they reset.

I came up blank about anyone else encountering this issue a few months ago from searching around so I thought i might bring it to the community for some input or suggestions to try and narrow down whats causing this as this has been a long time issue that I've really put off.
Attachments:

Please Log in or Create an account to join the conversation.

7 months 5 days ago #2 by Wobbles
Try using macros instead, or give IM 1.7 a shot

Please Log in or Create an account to join the conversation.

7 months 5 days ago #3 by Raddan
Macros don't seem to be very friendly, I can't get them to work correctly, it seems to either ignore when i have 'w' press -> 'w' release and it seems to just spam if i have it set on press&release, is there a better way? right now i'm just trying the macro thing out, havn't read a guide on using the macros yet :pinch:

Please Log in or Create an account to join the conversation.

7 months 5 days ago #4 by Wobbles
Macros loop unless you add a wait for release command between press and release.
The following user(s) said Thank You: Raddan

Please Log in or Create an account to join the conversation.

7 months 5 days ago #5 by Raddan
I have set up the macros, and i'll try this out and report my results on Friday 2/15

Please Log in or Create an account to join the conversation.

6 months 4 weeks ago #6 by Raddan
I definitely didn't forget to post on Friday (a lie)

Anyways, yes macros seem to be a workaround for my issue, the only thing I notice is that when using macros the controls are much more sensitive, and changing any of the stick settings (sensitivity, deadzones, ect) have no effect on the controller which is unfortunate.

Please Log in or Create an account to join the conversation.

6 months 4 weeks ago - 6 months 4 weeks ago #7 by wirenut48
You may be able to adjust the sensitivity with the keyboard repeat rate by going to "All Control Panel Items/keyboard" to bring up the keyboard properties settings. Or right clicking keyboard in Devices and Printers. Windows has done a good job of hiding those settings as you can't find them with a search.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

6 months 4 weeks ago #8 by Raddan
I should rephrase that, using the macros instead of binding the stick to a keyboard key causes the stick to have less of an angle for each activated key.

for example, when holding the stick forward, slight movement to the left or right would cause W+A or W+D to activate where as when the macros are not being used I have a wider arc I can move the stick before that combo is activated.

It appears that whenever the stick is moved off from the absolute position (staight up, left, right, down) that triggers the macro, it will trigger the next macro that the stick moves twords and will hold down that key until it reaches a new absolute position that triggers a macro.

Please Log in or Create an account to join the conversation.

6 months 4 weeks ago #9 by wirenut48
An AXIAL type deadzone which would be applied to the full length of the X,Y axis should work for that.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

6 months 4 weeks ago #10 by Raddan
As stated above:

and changing any of the stick settings (sensitivity, deadzones, ect) have no effect on the controller which is unfortunate.


This applies to both radial and axial deadzones.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum