Site Login

This Months Donations

$38.93
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Jon
$10.00
Nikita
$2.00
Gregory McCoy
$2.00
Karl Scahill
$2.00
Frederick J Hogsett
$5.00
Number of donations
12
Highest donation
$10.00
Average donation
$3.67

Inconsistent latency

3 years 6 months ago - 3 years 6 months ago #1 by JustApollo
I have a pretty weird problem. Running latest windows 10, 4.0 bluetooth spec, and plugged into a USB2.0 port. My computer is only 5 feet away from the controller, max. This happens both when using exclusive mode, and not, with the least amount of latency set in the settings. The latency is incredibly inconsistent. Sometimes I'll connect, and it'll report 1ms latency, and stay like that. I know its not misreporting because moving the mouse is silky smooth, with little to no jittering. Sometimes I'll connect and report 20-30ms latency and stay like that, and the mouse is very jittery. It only changes between these two when I disconnect the controller, restart the InputMapper and reconnect. Though, I almost always get the 30ms latency, I feel like I have to keep disconnecting and reconnecting until I get the 1ms latency. Any idea what could cause this?

Please Log in or Create an account to join the conversation.

3 years 6 months ago #2 by JustApollo
Wow, I found out what the problem was. Turns out, the latency spikes happen when the bluetooth settings app is open. I dunno know if its a problem with InputMapper or Windows.

Please Log in or Create an account to join the conversation.

3 years 6 months ago #3 by Wobbles
If you have the BT settings app open that means its scanning for devices. That takes BT bandwidth, thus the latency impact to other devices. Its not a problem, just how it is.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum