Site Login

This Months Donations

$34.52
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Gregory McCoy
$2.00
jhonatan felipe
$2.00
Frederick J Hogsett
$5.00
Karl Scahill
$2.00
lookingglassties
$2.00
Number of donations
11
Highest donation
$5.00
Average donation
$3.25

Recent Win 10 14366.rs1_release.160610-1700

3 years 7 months ago #1 by daveisthemusic2
Hi... exclusive mode now isn't working for me - even when killing explorer in task manager.

Is there a specific system service that needs to be running for exclusive mode to work?

I have disabled some needless stuff in there (but I never had any problem with exclusive mode before the recent update).

Shared mode seems to be working fine, trackpad works in windows...

Has anyone else had exclusive mode problems with this latest release..?

Many thanks

Please Log in or Create an account to join the conversation.

3 years 7 months ago - 3 years 7 months ago #2 by daveisthemusic2
Just to add, I rolled back the newest 360 drivers to the 2009 version in device manager, because I remembered doing this a while ago and it fixed something with InputMapper. But still no luck with exclusive mode this time, however.

Please Log in or Create an account to join the conversation.

3 years 7 months ago #3 by Wobbles
I am unfamiliar with that release, most recent Windows 10 for me is v1511 (10586.420). You should not be using ANY 360 drivers, I would remove all of those for starters as 360 controller drivers have been built into DirectX for some time now.

Its usually applications that cause issues with exclusive mode, not services or explorer. What other UWP apps could be running?

Please Log in or Create an account to join the conversation.

3 years 7 months ago #4 by daveisthemusic2
Thanks for getting back... I'm on windows insider so I guess this is a preview build that installed itself around a week ago...

When I say 360 driver, I mean this in device manager (see attached pic).

If I uninstall it, then the 360 Controller disappears from windows controllers - but on reconnecting the DS4 with Inputmapper, it just reinstalls itself automatically. What I meant is that here I have a choice here between using the most recent 360 driver (2016) or a 2009 one - but neither gives exclusive mode working, anyway.

Also - yes I have closed down all apps, no steam/other apps running in task manager... rebooted several times, very strange.

I was playing Dark Souls 3 no problems at all a few weeks ago, I'm thinking it must be something to do with this latest update...?
Attachments:

Please Log in or Create an account to join the conversation.

3 years 7 months ago #5 by daveisthemusic2
- I also tried installing the SCP driver again and it said there was errors during the install, so I checked the log and it says installation successful - but it still mentions errors for some reason?

---

Detected - Microsoft Windows 10 Pro Insider Preview (6.2.9200.0 AMD64)
Selected DEFAULT configuration.

INFO - ENTER: DriverPackageInstallW
INFO - Looking for Model Section [SCProductions.NTamd64]...
INFO - Installing INF file 'C:\Program Files (x86)\DSDCS\InputMapper\Virtual Bus Driver\System\ScpVBus.inf' (Plug and Play).
INFO - Looking for Model Section [SCProductions.NTamd64]...
INFO - Installing devices with Id "root\ScpVBus" using INF "C:\WINDOWS\System32\DriverStore\FileRepository\scpvbus.inf_amd64_21ca245c0e23d7a5\scpvbus.inf".
INFO - Will force install because driver is not better and force flag is set.
INFO - ENTER UpdateDriverForPlugAndPlayDevices...
SUCCESS - RETURN UpdateDriverForPlugAndPlayDevices.
INFO - Installation was successful.
SUCCESS - Install completed
INFO - RETURN: DriverPackageInstallW (0x0)

There were errors during the install, see the log for details. [Reboot Required]

-- Install Summary --
Bus Driver

Please Log in or Create an account to join the conversation.

3 years 7 months ago #6 by Wobbles
The install looks good to me, I would seriously get off the insider build though, those things are alwayse buggy and its hard enough to diagnose issues when the OS itself is in a beta state.

Please Log in or Create an account to join the conversation.

3 years 6 months ago #7 by daveisthemusic2
Thanks for your email to us users today, Wobbles.

Told you though eh... good old insider builds for picking up early on things, we could have had this reported a month ago ;)

Because exclusive mode was working before the 14366.rs1_release.160610-1700 update, it had to be something that Microsoft implemented in that incremental update that is the cause of all this.

Anyway, thanks for pushing the issue now. Clicked "Me Too" on a few devices, let's hope Microsoft can get this fixed in another update soon.

Please Log in or Create an account to join the conversation.

3 years 6 months ago #8 by Wobbles
We purposefully do not address issues with insider builds as they are impossible to debug and full of their own issues.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum