Site Login

This Months Donations

$89.56
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Rain
$2.00
Fahad
$2.00
Carlo
$5.00
m3rlinsbart
$2.00
Thank you - works great with Pokemon Desmume Emulator!
Katie
$2.00
Number of donations
15
Highest donation
$50.00
Average donation
$6.53

win10 issues despite ExclusiveModeTool.exe

3 years 2 months ago #1 by fejwin
I am on Windows 10 with Anniversary Update installed.
The ExclusiveModeTool.exe properly allows InputMapper to get my DS4 controller in exclusive mode.
From InputMapper perspective all should work fine. However

Dark Souls and Dark Souls 3

do not recognize the DS4 controller at all. Prior to win10 anniversary update all worked fine.
I tried to reinstall steam and the games, tried several InputMapper versions. Nothing helps so far.
Any suggestions?

Please Log in or Create an account to join the conversation.

3 years 2 months ago #2 by Wobbles
Try using joy.cpl and setting your default controller to the 360 one
The following user(s) said Thank You: fejwin

Please Log in or Create an account to join the conversation.

3 years 2 months ago #3 by fejwin
When I open up joy.cpl I see no controllers listed there at all (DS4 not yet connected through input mapper).
Might that be because I uninstalled a bunch of standard windows apps (and xbox app along with them)?
Any Suggestion how to fix this?

Please Log in or Create an account to join the conversation.

3 years 2 months ago #4 by Wobbles
If the controller isn't connected it wont show up
The following user(s) said Thank You: fejwin

Please Log in or Create an account to join the conversation.

3 years 2 months ago #5 by fejwin
Connected DS4 through input mapper, XBOX360 showed up in joy.cpl, clicked on advanced and set it to be default choice for older applications. Tried the games - still no reaction. Is there anything else I can try?

Please Log in or Create an account to join the conversation.

3 years 2 months ago #6 by Wobbles
do the input work in xinput test? and does your log infact say that the controller is being used exclusively

Please Log in or Create an account to join the conversation.

3 years 2 months ago #7 by fejwin
Yes the XInput test works fine, all the buttons light up when I press them.

Here is the log:

10/8/2016 8:46:10 AM> INFO: Starting...
10/8/2016 8:46:10 AM> INFO: Searching for controllers....
10/8/2016 8:46:10 AM> INFO: Using Exclusive Mode
10/8/2016 8:46:11 AM> TRACE: Active application changed to C:\Program Files (x86)\DSDCS\InputMapper\InputMapper.exe
10/8/2016 8:46:15 AM> TRACE: Device connected 459780|32768|19848992
10/8/2016 8:46:16 AM> TRACE: 90:FB:A6:9C:16:A5 device start
10/8/2016 8:46:17 AM> INFO: Found Controller: 90:FB:A6:9C:16:A5 (BT)
10/8/2016 8:46:17 AM> INFO: Controller 1 is using Profile "myNewProfile01" in exclusive mode.
10/8/2016 8:46:17 AM> TRACE: 90:FB:A6:9C:16:A5 power subsystem octet: 0x07
10/8/2016 8:46:17 AM> TRACE: Device connected 459780|32768|19849072
10/8/2016 8:46:20 AM> TRACE: Active application changed to C:\Program Files (x86)\DSDCS\InputMapper\XInputTest.exe
10/8/2016 8:46:26 AM> TRACE: Active application changed to C:\Program Files (x86)\DSDCS\InputMapper\InputMapper.exe
10/8/2016 8:46:35 AM> TRACE: Active application changed to C:\Program Files (x86)\DSDCS\InputMapper\InputMapper.exe

Please Log in or Create an account to join the conversation.

3 years 2 months ago #8 by Wobbles
Shows as controller 1 in xinput correct?

Please Log in or Create an account to join the conversation.

3 years 2 months ago - 3 years 2 months ago #9 by fejwin
Yes, Controller 1 is selected and registers button pushes in XInput, for Controller 2,3,4 XInput says "Not Connected".

Please Log in or Create an account to join the conversation.

3 years 2 months ago #10 by Wobbles
well everything definitely seems properly set up, are then any settings in DS for input selection?

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum