Site Login

This Months Donations

$535.62
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Sven Eckelmann
$10.00
Nick van de Wall
$500.00
making life on the road more fun thnx
Eric Cota
$2.00
Ricardo Nunes
$2.00
Nick
$2.00
Number of donations
21
Highest donation
$500.00
Average donation
$25.41

It connects, but it doesn't work! windows 10

2 years 9 months ago #1 by rockappalla
Hi everybody!
I want to play Battlefield bad company 2, I downloaded Input mapper, connected both a PS4 and a X360 controller and they both work fine in the Xinput test, but the analog sticks don't work in game or for what it matters in windows, they should act like WASD keyboard (left stick) and a mouse (right stick)? '- yes, I have assigned them to the corresponding sticks, but still nothing!
can you help me? I can't really play on kB/mouse!

Thanks for your help!

Please Log in or Create an account to join the conversation.

2 years 9 months ago #2 by rockappalla
Warning: Spoiler! [ Click to expand ]

Please Log in or Create an account to join the conversation.

2 years 9 months ago #3 by Wobbles
Did you assign the profile to the controller? By default IM takes a PS4 controller and creates a 360 one.

Please Log in or Create an account to join the conversation.

2 years 9 months ago #4 by rockappalla
yes, i saved a new profile, but I can't get the analog sticks to move the mouse cursor, even if in the xinput test they work...

Please Log in or Create an account to join the conversation.

2 years 9 months ago #5 by Wobbles
xinput test does not detect mouse cursor movement, its meant for testing xinput. Did you assign the profile to the controller?

Please Log in or Create an account to join the conversation.

2 years 9 months ago - 2 years 9 months ago #6 by rockappalla

Wobbles wrote: xinput test does not detect mouse cursor movement, its meant for testing xinput. Did you assign the profile to the controller?

Maybe I'm missing something, how do you assign a profile to the controller?

Please Log in or Create an account to join the conversation.

2 years 9 months ago #7 by Wobbles
The dropdown menu under the controller, if it says default, then you havent assigned it.

Please Log in or Create an account to join the conversation.

2 years 9 months ago #8 by rockappalla
Thank you! it's now working in exclusive mode, but the mouse arrow is constantly going down, how do I adjust the settings ? the mouse is impossible to use when the controller is connected :)
thanks again for your help guys!

Please Log in or Create an account to join the conversation.

2 years 9 months ago #9 by Wobbles
Set the stick deadzone type to radial hard then increase the amount of deadzone to 2-3%

Please Log in or Create an account to join the conversation.

2 years 9 months ago #10 by rockappalla

Wobbles wrote: Set the stick deadzone type to radial hard then increase the amount of deadzone to 2-3%


I owe you a BIG beer!! thank you!!!

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum