Site Login

This Months Donations

$6.19
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Eddie Binda
$5.00
Gabriel Pena
$2.00
Jon
$10.00
Nikita
$2.00
Frederick J Hogsett
$5.00
Number of donations
2
Highest donation
$5.00
Average donation
$3.50

InputMapper minor problem, works, but shows a problem message.

3 years 4 months ago #1 by metalhusky
So the controller works correctly, but this message comes up (my vindowns is german, but there is a short video i made to show what i mean \/):

"Input Mapper doesn't function anymore" It says, also:
There is a problem that prevents this programm to be executed correctly. Close the programm.

If i click "Close programm" nothing happens, i can minimize it and click on the icon again and the same window opens again.

I think it started happening with the last version 1.6.10 .

It started a few months ago, as i said, the controller works, but it's annoying.

BTW InputMapper starts at windows startup, before Steam.

Please Log in or Create an account to join the conversation.

3 years 4 months ago #2 by Wobbles
run windows update and make sure you have all your .net patches and service patches aswell.

Please Log in or Create an account to join the conversation.

3 years 4 months ago #3 by metalhusky
I always keep everything up to date, but i use Ancile, which is a programm that turns off Windows Telemetry, it can be fought on Win 7 better then on Win 10, so i already thought that might be the thing that causes that window popping up, but i ran Ancile for many many months now and also used DS4windows and then InputMapper without any problems.

And as i said even, now the controller works just fine, it's just that if i want to change something in the settings or check the battery or something like that and click on the icon this message pops up, but the controller still works perfectly, thats why i said it's just a minor issue, an annoyance more then anything.
But still.


PS Keep it up, an awesome programm you got there!

Please Log in or Create an account to join the conversation.

3 years 4 months ago #4 by Wobbles
give 1.7 a shot, its still in alpha, but in many regards more stable than 1.6

Please Log in or Create an account to join the conversation.

3 years 4 months ago #5 by metalhusky
I tried 1.7 now, but it broke my install, so i just reinstalled the current stable and will just wait for regular 1.7.

Please Log in or Create an account to join the conversation.

3 years 4 months ago #6 by Wobbles
1.7 is not compatible with simultaneous installs next to other IM's

Please Log in or Create an account to join the conversation.

3 years 4 months ago #7 by metalhusky
Look, 1.7 just doesn't work on my system. I just uninstalled 1.6.10 to try 1.7 again and no, doesn't work. Black window is all i get.
Here is a video. And btw, what i was showing also, but OBS somehow didn't record the overlay, was CPU usage, it was at 85% when 3 IM's were open(i didn't see them right away, but you will see that in the videos still.)

Please Log in or Create an account to join the conversation.

3 years 4 months ago #8 by Wobbles
can you shoot me the logs from 1.7, %appdata%\InputMapper\Logs

Please Log in or Create an account to join the conversation.

3 years 4 months ago #9 by metalhusky
Here.
Attachments:

Please Log in or Create an account to join the conversation.

3 years 4 months ago #10 by Wobbles
Looks like windows is missing a prerequisite or it is corrupt: "PresentationFramework.Aero2", may need to re-install .net 4.6.2 and make sure windows updates are installed

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum