Site Login

This Months Donations

$552.80
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
jhonatan felipe
$2.00
Karl Scahill
$2.00
Frederick J Hogsett
$5.00
SiesMAN01
$2.00
André Philipi da Silva
$2.00
Number of donations
28
Highest donation
$500.00
Average donation
$19.97

DS4 AS controller 2

2 years 3 months ago - 2 years 3 months ago #1 by Hast0n
I have problem when i connect my DS4 it takes 2nd place in xinput so my games doesnt recognize it. On the 1st place i have "ghost" controller i tried to turn of the shadow play and delete the xbox 360 controller for windows from device manager and restart my pc and nothing helped dont know what to do next can someone help me :) (sorry for my english) btw after uinstal IM the ghost controller disappeared and when i instalit again it appears. soo i think its someting wrong with IM. BWT I have no controller connected
Attachments:

Please Log in or Create an account to join the conversation.

2 years 3 months ago #2 by relsig
Hi! Please see the developer's post about how to make a proper post requesting support:

inputmapper.com/forum/inputmapper-1-5-su...t-requesting-support

Currently, unless someone replies and has had your exact issue there's no way to determine what the cause is. If you provide the info requested from wobbles' post someone will probably be able to help. If it's something obviously suspicious I'll point it out for you.

Additionally the "ghost" controller is a bit non-descript. Does it appear in windows controllers? Inputmapper? Device manager? What is the exact text (is it called "ghost controller"?). A picture is worth a thousand words and would probably be easier than typing it.

Please Log in or Create an account to join the conversation.

2 years 3 months ago #3 by Hast0n
And when i connect my controller it looks like this. ctrlv.cz/MTFH and xinput ctrlv.cz/yaYB

Please Log in or Create an account to join the conversation.

2 years 3 months ago - 2 years 3 months ago #4 by relsig
for future people who might chime in:
the issue you have is games aren't recognizing controller input from your device. Your controller shows up twice in the device manager when it's connected. It looks like it shows up once once even if it isn't connected, but only when you have inputmapper installed.

You're running the most recent stable release (1.6.10.19991)
There's nothing suspicious in your vbus log.
this is your vbus log:
Warning: Spoiler! [ Click to expand ]


there's still a few things we're missing:
- how are you connecting it to the computer? (wired, generic bt dongle, sony dongle?)
- what version of windows are you running? (Whole version, including os number, version, and build - run winver.exe to get this)
- can you provide an application log? (Go to the log tab in inputmapper and click [Copy Log])

the application log is very important and will tell us things like if you have exclusive mode, if there were general issues, etc.

Please Log in or Create an account to join the conversation.

2 years 3 months ago - 2 years 3 months ago #5 by Hast0n

Hast0n wrote: And when i connect my controller it looks like this. ctrlv.cz/MTFH and xinput ctrlv.cz/yaYB

(if you dont see it there im using sony usb wireless adapter

Win : windows 10 Pro version 1703 (os build 15063.483


and here is my application log

Warning: Spoiler! [ Click to expand ]

Please Log in or Create an account to join the conversation.

2 years 3 months ago #6 by relsig
You'll want to grab the log after connecting the controller as it will have important device specific information.

Also did you install HIDGuardian ?

Please Log in or Create an account to join the conversation.

2 years 2 months ago - 2 years 2 months ago #7 by Hast0n
Warning: Spoiler! [ Click to expand ]





connected when steam is running so its not in exlusive mod but without steam it will connect to the exclusive and no i didnt instal anything

Please Log in or Create an account to join the conversation.

2 years 2 months ago #8 by Hast0n
Warning: Spoiler! [ Click to expand ]
he is with no steam turned on

Please Log in or Create an account to join the conversation.

2 years 2 months ago - 2 years 2 months ago #9 by relsig
Hidguardian will prevent steam from grabbing the controller, so I would definitely try it. Normally problems sending input are related to exclusive mode.

I don't see anything obviously fishy in any of your logs.

If you disconnect the Sony dongle does the ghost controller go away?

Does exclusive mode make your input work?

Please Log in or Create an account to join the conversation.

2 years 2 months ago #10 by Hast0n
my exclusive mode is working.
the ghost controller will go away only if i uinstall IM

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum