Site Login

This Months Donations

$551.19
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Karl Scahill
$2.00
Frederick J Hogsett
$5.00
SiesMAN01
$2.00
André Philipi da Silva
$2.00
lookingglassties
$2.00
Number of donations
27
Highest donation
$500.00
Average donation
$20.61

Insane latency

2 years 2 months ago #1 by RGV9
Hello, new to the forum, so first post.

I'm having a problem with my DS4's latency (on Windows 10). When I first turn it on it spikes up to as high as 100+ms. Insane. Then it comes down but it always remains at about 30ms. Interestingly, this didn't happen to me before, but after a period of about 5 days without using my controller or PSP emulator, this suddenly happened. Before, it ocassionaly spiked above 14ms but nothing crazy, just slightly above.

I can't find the cause for this. I've tried many different things. I've updated the drivers from device manager, I've unchecked the box for allowing Windows to turn the device off to save power, I tried modifying my power plan to high performance, I've uninstalled and reinstalled Inputmapper, restarted the OS, etc, etc, etc. I've tracked down what other things I had done in that period of inactivity from gaming that could've altered important settings, but all I remember doing is modifying my Windows 10 privacy settings, and not much else. Normally I'm really OCD when it comes to fixing things on my PC so I usually find a solution sooner or later, but this one really has me stuck.

I'd appreciate any help, and please do ask for more details if necessary.
Cheers.

Please Log in or Create an account to join the conversation.

2 years 2 months ago #2 by RGV9
Hello, I'm reporting back because after a horrific struggle of confusion, frustration, and nearly giving up after trying pretty much everything, I think I've found the solution, at least for now. To clarify, I'm on an ASUS T100 Transformer Book using only the tablet because the keyboard dock (along with a 500gb hard drive) broke, so I'm using a keyboard and a mouse on bluetooth. I was having some issues with these, especially the keyboard, in that sometimes it seemed to lag and repeat keys infinitely even though I wasn't pressing them. So I searched for a fix for that and I ended up disabling a certain option in the device manager under "bluetooth collaboration" for the broadcom network adapter. All I know is that it has something to do with WiFi-BT interference.

Anyway, and for the sake of not getting to technical here, it turns out that after experimenting with reverting that function my DS4 started working properly again without major latency, after failing to do so with ABSOLUTELY EVERYTHING ELSE. My latency was going as high as 100ms. It was surreal. So, basically what I did was re-enable bluetooth collaboration, and that fixed my DS4 latency issues. Of course, whenever I want to use my BT mouse & keyboard, I have to disable it again.

I made a little image summary to serve as a quick and easy guide in case I forget, and I'll post it here if by any chance anyone runs into the same problem as me and can't find any other way to fix it.

Cheers.
Attachments:

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum