Site Login

This Months Donations

$545.03
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
SiesMAN01
$2.00
André Philipi da Silva
$2.00
lookingglassties
$2.00
Keanu Allridge
$5.00
Sven Eckelmann
$10.00
Number of donations
25
Highest donation
$500.00
Average donation
$21.92

exclusive mode errors

1 year 9 months ago #1 by Ashkan K
I was using IM yesterday and it was working fine but now there is an exclusive mode error. I am using IM version 1.6.10.19991. I have windows 10 version 1703, OS build 15063.786. I have tried closing applications like nvidia and steam, as well as turning of share on nvidia.Whenever I plug in my controller it says: " WARNING: Warning: Could not open DS4 DC:0C:2D:00:82:44 exclusively. You must quit other applications like Steam, Uplay before connecting a controller using the exclusive mode option." followed up by: "WARNING: We are still unable to open the device exclusively even after running the exclusive mode tool for Win 10 AU. The issue likely resides in another application open that is trying to access the controller." I have tried using the HID Guardian. Log:
Warning: Spoiler! [ Click to expand ]

Please Log in or Create an account to join the conversation.

1 year 9 months ago #2 by wirenut48
Do you need it, if not just ignore and play on.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 9 months ago - 1 year 9 months ago #3 by Ashkan K
If any more info required pls ask

Please Log in or Create an account to join the conversation.

1 year 9 months ago #4 by Ashkan K

wirenut48 wrote: Do you need it, if not just ignore and play on.

i have a crap trackpad

Please Log in or Create an account to join the conversation.

1 year 9 months ago - 1 year 9 months ago #5 by wirenut48
So I take it you do need exclusive mode for playing a non controller game. Right now it's really hit and miss getting it working, Windows keep changing the way input devices are handled, So right now the development of a driver filter for exclusive mode is constantly being broken.

These game developers need to add proper controller support to their games. Then exclusive mode wouldn't be an issue.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 9 months ago #6 by Ashkan K

wirenut48 wrote: So I take it you do need exclusive mode for playing a non controller game. Right now it's really hit and miss getting it working, Windows keep changing the way input devices are handled, So right now the development of a driver filter for exclusive mode is constantly being broken.

These game developers need to add proper controller support to their games. Then exclusive mode wouldn't be an issue.


Yeah, definetely. But Far Cry 4 is meant to support DS4 and xbox controllers. However when i use it the controls are jumbled up and this stopped when i downloaded IM and turned on exclusive mode.

Please Log in or Create an account to join the conversation.

1 year 9 months ago #7 by wirenut48
The game should let you pick the controller you want to use. If it allows input from all controllers, yea it will be jumbled up.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 9 months ago #8 by tremendoza
If it supports DS4 then run the game without IM.

Please Log in or Create an account to join the conversation.

1 year 9 months ago #9 by Lawrence A Fossi
I found that when I updated to the latest Creator's Update I no longer had exclusive mode. I took a look in the event viewer and saw there were HidGuardian errors related to .net I fixed them by going to Control Panel>Programs and Features click on Turn Windows Features on or off (left pane) and scroll untill you find .net. Mine was just a black box indicating that not all components were installed. I checked all the boxes, Windows downloaded the rest of the components creating folders in C:\users for installation.I have no idea what version of .net HidGuardian needs and checking all the boxes will install .net(s) 2.0 3.0 3.5 4.5 some tagged as legacy. Before only .net 4.7 components were installed by default..Could be some security concerns by adding all the old .nets but even if I knew which one HidGuardian needed I wouldn't know which boxes to leave unselected.
Note I uninstalled HidGuardian first as well as deleting the wireless controller from Settings> Bluetooth and Devices.
After rebooting I reinstalled HidGuardian and redid the pairing process. Inputmapper is now working flawlessly. I can grab exclusive mode at anytime without quitting Steam first even if I've already launched the game I can alt-tab out start Inputmapper & pair the controller, turn off the controller when taking a break and turn it back on later have yet to see exclusive mode fail. Works great with GOG games too without turning off Steam. Tested for 2 weeks before posting. Not saying this will help in your case but another possibility to check.
Oh I'm also still using this bluetooth adapter from Windows 8.1 working just fine under Win 10. www.amazon.com/SMK-Link-Nano-Dongle-Blue...VP6495/dp/B0093HNIBO
Hopefully this may help someone especially in relation to HidGuardian issues.
Could the .net version requirement be added to the Hiduardian page?

Please Log in or Create an account to join the conversation.

1 year 9 months ago - 1 year 9 months ago #10 by wirenut48
Thanks DarkFoss, got it working again even though I don't need it. That last update broke it for me too after I had finally got it working with the 2nd Gen ID's added. Didn't see any guardian errors on my end but checked all .Net anyway then uninstalled/installed guardian and added my second gen controller ID's back to the white List. When done I unchecked the boxes in .Net like they were before and it is still working. So I'm not sure if that had anything to do with it for me, more than likely the guardian uninstall/install did the trick. I thought I tried that already, but may of just did a reinstall without uninstalling first as I wasn't to worried about it not working.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum