Site Login

This Months Donations

$551.19
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Karl Scahill
$2.00
Frederick J Hogsett
$5.00
SiesMAN01
$2.00
André Philipi da Silva
$2.00
lookingglassties
$2.00
Number of donations
27
Highest donation
$500.00
Average donation
$20.61

Rapid-Fire Macro

1 year 8 months ago - 1 year 8 months ago #1 by Jacka5597
Hi,

Been trying to figure this out for a few days, watched all the tutorials. I have been trying to create a macro that whilst activated or toggled on, it will repeatedly press R2. want it so I can cruise Los Santos on push bike faster without having to spam the actual button itself.

I have created a small workaround, where if R2 and Square are pressed it will press R2, allowing me to repeated press square giving me the same effect which I do find easier to do, until I try to turn in which case it goes back to the default pedaling mode.

I have tried
R2 + Square pressed
= press R2, delay (0.5), release
= press R2, delay (0.5), release, wait for re-trigger
= press R2, delay (0.5), release, this repeated a few times
= press and release R2
= press and release R2, wait for re-trigger
= press and release R2, repeated a few times


I am stumped.

Please Log in or Create an account to join the conversation.

1 year 8 months ago - 1 year 8 months ago #2 by wirenut48
This feature is planed in the 1.7 update but don't think it's possible with the current version. You only have the basic press and release or hold press until release. No repeat until released. Best you could do is a set series of presses with one press.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 8 months ago - 1 year 8 months ago #3 by Jacka5597
Ah, will try the series of presses again then, thanks

EDIT: About 20 minutes later when getting to actually try the series macro out, i tried again didn't work shortened the delay to 0.1, didn't work had to shorten it to 0.01. which if i'd have tried before posting this would have solved my issue.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum