Site Login

This Months Donations

$551.19
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Karl Scahill
$2.00
Frederick J Hogsett
$5.00
SiesMAN01
$2.00
André Philipi da Silva
$2.00
lookingglassties
$2.00
Number of donations
27
Highest donation
$500.00
Average donation
$20.61

ds4 connects then immediately disconnects with read failures on wired connection

1 year 6 months ago - 1 year 6 months ago #1 by Pomparomp
The exact length of how long I'll stay connected varies. Sometimes right after a reboot it'll work for an hour or so before failing, other times I can never even get it to stay connected for longer than a few seconds. I'm using a second gen controller. Things worked fine at one point months ago with an old roommates first gen controller, but I've been struggling to get things to work right for weeks since buying my own.

When I first plug in, I'll get 1, then a few moments later 2 controllers showing up both in device manager and IM before one disconnects, then a few moments later the other disconnects from IM while one remains in device manager.

Windows version 1709, build 16299.334

vbus log

Preparing to load DIFxAPI
Running as 64-Bit process
DIFxAPI path: C:\Program Files (x86)\DSDCS\InputMapper\Virtual Bus Driver\DIFxApi\amd64\DIFxAPI.dll
Loaded library: C:\Program Files (x86)\DSDCS\InputMapper\Virtual Bus Driver\DIFxApi\amd64\DIFxAPI.dll
ScpVBus.inf path: C:\Program Files (x86)\DSDCS\InputMapper\Virtual Bus Driver\ScpVBus\ScpVBus.inf
DIFXAPI_INFO: 0 ENTER: DriverPackageInstallW
DIFXAPI_INFO: 0 Looking for Model Section [SCProductions.NTamd64]...
DIFXAPI_INFO: 0 Installing INF file 'C:\Program Files (x86)\DSDCS\InputMapper\Virtual Bus Driver\ScpVBus\ScpVBus.inf' (Plug and Play).
DIFXAPI_INFO: 0 Looking for Model Section [SCProductions.NTamd64]...
DIFXAPI_INFO: 0 Installing devices with Id "root\ScpVBus" using INF "C:\Windows\System32\DriverStore\FileRepository\scpvbus.inf_amd64_21ca245c0e23d7a5\scpvbus.inf".
DIFXAPI_INFO: 0 Will force install because driver is not better and force flag is set.
DIFXAPI_INFO: 0 ENTER UpdateDriverForPlugAndPlayDevices...
DIFXAPI_SUCCESS: 0 RETURN UpdateDriverForPlugAndPlayDevices.
DIFXAPI_INFO: 0 Installation was successful.
DIFXAPI_SUCCESS: 0 Install completed
DIFXAPI_INFO: 0 RETURN: DriverPackageInstallW (0x0)

IM log

Warning: Spoiler! [ Click to expand ]

Please Log in or Create an account to join the conversation.

1 year 6 months ago #2 by Pomparomp
The duplicate stays "connected" even when i unplug the ds4

i.gyazo.com/efb034fbab2b3178e07519e51e61c546.png

Please Log in or Create an account to join the conversation.

1 year 6 months ago #3 by wirenut48
Not very good at deciphering log files but having a USB controller with no Mac address looked specious. You may have to remove that HID game controller from the Device Manager. If your not using any other controller just uninstall them all and start clean.

Viewing that last pic you put up does look like you have a ghost 360 controller, which would explain the 360 duplicates. Just uninstall all the 360 controllers hidden or not with IM not running.

Couple of questions. Have you ever paired the DS4 with BT? That would show duplicate DS4 in the Device Manager if a USB is then connected. Did you use any other SCP driver installer other than the one from IM install directory? Looked like there was some kind of version comparison check when loading the driver, but this could be normal.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 6 months ago - 1 year 6 months ago #4 by Pomparomp
I've never once used bluetooth. I used the old SCP tools back in the day, but that was an OS and 3 hard drives ago so I wouldn't know where to go to get rid of old files

Edit: Having change approximately nothing it's started working right the last two days straight, computers are weird.

Edit: It broke again

Please Log in or Create an account to join the conversation.

1 year 6 months ago - 1 year 6 months ago #5 by wirenut48
Would be best to open a support ticket so the developer could take a look at the log files.
I would start by uninstalling all the 360 devices (including hidden) you showed in your pic from the Device manager. There should only be one per controller, it will reinstall itself. Just right click to uninstall.
Second uninstall the SCP driver listed in the device manager/system devices tab and reinstall with the driver located in the IM install directory. Make sure to reboot after each step.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 6 months ago #6 by Pomparomp
I did all of the above, and it worked right for about a day but now it never connects to inputmapper, and the charging light just goes blank

Please Log in or Create an account to join the conversation.

1 year 6 months ago #7 by wirenut48
I'm not seeing any issues with my second gen controller connecting USB. Log below, started IM, plugged in controller.

Warning: Spoiler! [ Click to expand ]

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 5 months ago #8 by Pomparomp
It's worked steady for about a week now. I noticed it would work fine (now, after doing the above steps) after doing a reboot, and started disconnecting the controller before putting my computer into sleep mode at night. No more duplicate devices

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum