Site Login

This Months Donations

$54.33
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Joachim
$2.00
Alberto Bottero
$5.00
Yoshihisa
$5.00
Reuben Clark Fox
$10.00
Benjamin
$2.00
Number of donations
18
Highest donation
$10.00
Average donation
$3.44

Exclusive mode failing in W10 April 2018 update

1 year 5 months ago #11 by Idkappa
@wirenut48, I've done it again now. It told me to reboot and i did it, unfortunately it didn't help. Still not able to get exclusive mode.
Do you have any other Solutions? Thank you anyway for trying to help me

Please Log in or Create an account to join the conversation.

1 year 5 months ago #12 by wirenut48
Bet you're wondering, why you. Sounds like HIDGuardian is getting installed. Haven't heard of anyone not having it work with a fresh install.
Do you need it? If you do you will need to figure out what you got installed on your PC that is keeping it from running. Posting your logs will be a good way to start.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 5 months ago #13 by Idkappa
So i've tried InputMapper without HIDGuardian and it worked for a while. But due to an Update nothing worked anymore so i installed it and everything was fine. But now i get the exclusive mode issues again, and reinstalling didnt fix it. Here are the Logs you asked for.
Warning: Spoiler! [ Click to expand ]

Please Log in or Create an account to join the conversation.

1 year 5 months ago - 1 year 5 months ago #14 by wirenut48
InputMapper and HIDGuardian are two seperate Apps, though IM does rely on guardian to achieve exclusive mode. IM should run on it's own without any problems and is not effected by updates. So you should not have to install Guardian to get IM working (without Exclusive Mode). Guardian will hide the DS4 from IM if the whitelister service is not there and running, so if Guardian is not fully removed it can cause problems with IM.

So what you are telling me makes no logical sense in that IM was working without Guardian but the update broke it. IM won't do exclusive mode without guardian and only guardian is affected by major updates. I still think your issues are with guardian not installed properly or something blocking it which I haven't heard of anything doing that. But if your games don't need it, then I wouldn't worry about it not working.

Since it's not working I would uninstall guardian then make sure the driver is gone and IM is working, minus exclusive mode, after rebooting.
Once you have verified it is uninstalled and IM is working properly you can reinstall if needed.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 5 months ago #15 by Idkappa
First of all, with not Working i mean that i couldn't play my Games without issues. And i was able to play them first without HIDGuardian. After a windows update it started to cause issues so i read through this site and found that someone said HIDguardian would help, so i installed it and it worked. Now with or without HIDguardian, i get the same Warnings from Inputmapper and i cant play FIFA without any issues. i uninstalled and reinstalled hidguardian now a few times, is there a way to check if the drivers are removed? I had to reboot my computer when i uninstalled it, as you said, but nothing changed. still the same warnings and same problems.
btw, i really appreciate your help.

Please Log in or Create an account to join the conversation.

1 year 5 months ago - 1 year 5 months ago #16 by wirenut48
Without exclusive mode you can get double inputs (from the DS4 and virtual 360) from games that allow input from multiple devices. FIFA I do believe is one that has this issue so guardian is needed.

I still can't figure out why it isn't working for you. But it doesn't sound like you have read my sticky thread on "how to get exclusive mode working" here in the forum. I haven't heard of any one else reporting issues after reinstalling using the instructions in the thread. It includes troubleshooting with driver info.

inputmapper.com/forum/inputmapper-1-5-su...-2nd-gen-controllers

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 5 months ago #17 by Idkappa
"2) If your using 2nd gen DS4 controller you'll need to edit the AffectedDevices registry value via regedit to add the controller's ID's so HidGuardian can hide the controller. This gets reset with a uninstall of HIDGuardian from step 1.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HidGuardian\Parameters\AffectedDevices

Here are the lines that should be used for a version 2 controller. The first 3 lines are for a USB connection and the 4th is for a BT connection. Double click AffectedDevices then copy and paste the four lines below to the end of the AffectedDevices List.

HID\VID_054C&PID_09CC&REV_0100&MI_03
HID\VID_054C&PID_09CC&MI_03
HID\VID_054C&UP:0001_U:0005
HID\{00001124-0000-1000-8000-00805F9B34FB}_VID&0002054C_PID&09CC

3) Check that HIDGuardian Virtual Device, SCP Virtual Bus Driver(IM v1.6) and/or Virtual Gamepad Emulation Bus(IM v1.7) are listed in Device Manager\System Devices. Those are the drivers you need installed for IM and Guardian. Also check in the Task Manager under Services and make sure Inputmapper Cerberus Whitelister is running, this is needed for the DS4 to show up in IM with HIDGuardian or no controller will be present. Inputmapper Cerberus Whitelister service is installed with the above version of HIDGuardian."

Done and checked all this stuff. And everything seems to be correct, haven't found anything missing except Virtual Gamepad Emulation Bus(IM v1.7) but i have the 1.6 so it shouldn't matter. Still getting the Warning unfortunately

Please Log in or Create an account to join the conversation.

1 year 5 months ago #18 by Idkappa
Uhm i just went into FIFA, trying to play and now it works but i haven't changed anything. Strange ...

Please Log in or Create an account to join the conversation.

1 year 5 months ago #19 by wirenut48
So is exclusive mode working for you now? I'm wanting to keep that topic updated including any problems that may exist, or find out why. That topic seems to be the most problematic issue with IM mainly because they are seperate installations.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 5 months ago #20 by Idkappa
It is, but i have no Idea why it didn't work before. Can't remember that i changed something.
Well, thanks for your help. I will inform you if any Problems appear.
The following user(s) said Thank You: wirenut48

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum