Site Login

This Months Donations

$25.60
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Jamie
$2.00
Rain
$2.00
Mikhail
$2.00
Gera
$2.00
Emma
$2.00
Number of donations
13
Highest donation
$5.00
Average donation
$2.21

DS4 No Longer Functioning At All Even After Complete Reformat of PC

1 year 3 months ago #1 by Mike
Hello I have been using InputMapper for years and it has generally worked well. However for the past few of months I cannot for the life of me get InputMapper to register my DS4 controller anymore. I have even downloaded DS4Windows and that cannot see it either.

The only way I can sometimes get it to work is by using SCPToolkit and even then every time my computer is restarted or put to sleep I have to manually download drivers again for it to register the controller. An interesting thing is, when my DS4 is connected via SCPToolkit and I open InputMapper, I am able to use the XInput Test, however no profile is available, nor am I able to start using InputMapper on its own.

This has been driving me up the wall for months now and I have tried so many different approaches including a complete reformat and clean installation of windows, so hopefully you guys can help shed some light on the issue.

Warning: Spoiler! [ Click to expand ]


Windows 10 Ver.1803
InputMapper Version: 1.6.10.19991

Please Log in or Create an account to join the conversation.

1 year 3 months ago #2 by wirenut48
You may have to reinstall InputMappers HIDGuardian to get the whitelister service running or Guardian will hide the DS4 from IM. Check this thread for troubleshooting.

inputmapper.com/forum/inputmapper-1-5-su...-2nd-gen-controllers

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 3 months ago - 1 year 3 months ago #3 by Mike
Hello thank you for the response, I have completely uninstalled and reinstalled HIDGuardian and have verified the services are running and devices are installed in device manager. Also I don't think it matter too much but I am using a first generation controller not the second gen.

Please Log in or Create an account to join the conversation.

1 year 3 months ago - 1 year 3 months ago #4 by wirenut48
So I take it that the controller is still not showing up in IM. Now we're getting into the WTF is going on phase. One of those other programs may have installed an incompatible SCP driver. Remove it from the Device Manager reboot the PC and install the SCP driver from the IM install directory, reboot again. Another thing you could do is go to the Device Manager and in the view menu and turn on show hidden devices. Go through it and remove any controller devices you find to clean it up.

Have you tried connecting controller using USB?

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 3 months ago - 1 year 3 months ago #5 by Mike
This morning before I opened this thread I did exactly that. I removed every 3rd party program from my pc thoroughly, I went into device manager and removed all unnecessary devices.

I have always installed IM first along with HIDGuardian because you guys have always been my preferred program to use and still no detection. Like I said the really weird thing is that IM alone will not detect my controller, but once I force install drivers from SCPToolkit I can access Xinput test via IM and it shows controller connected, yet I cannot change anything on the controller itself like light bar color, etc. If I close down SCPToolkit after force installing drivers then open IM it will not detect the controller, it only detects but cannot configure or actually use the controller if SCPToolkit remains open.

And yes I have only been connecting via USB due to not having a bluetooth connector on my PC.

Please Log in or Create an account to join the conversation.

1 year 3 months ago #6 by wirenut48
If an SCP driver exists it will not be overwritten by another version, I believe. So even installing IM first you may not have a compatible SCP driver installed if one already existed. Try what I suggested for replacing it and see if that works.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 3 months ago #7 by Wobbles
Make sure you do not have libUSBk drivers installed, they are incompatible.

Please Log in or Create an account to join the conversation.

1 year 3 months ago #8 by wirenut48

Wobbles wrote: Make sure you do not have libUSBk drivers installed, they are incompatible.


That depends on what they are/were used for. My FLIRC IR receiver used them and they coexisted just fine. So some people may need those for other devices.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum