Site Login

This Months Donations

$7.80
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Rain
$2.00
Eddie Binda
$5.00
Gabriel Pena
$2.00
Jon
$10.00
Nikita
$2.00
Number of donations
3
Highest donation
$5.00
Average donation
$3.00

Scarlet Crush Virtual Hub - No controller detected

3 years 10 months ago #1 by Eder
Hi, I found inputmapper after messing around with a directinput controller to get it to work on xinput only games. While setting up the program I installed a few basic plugins, Scarlet Crush 360 Virtual Bus, Directinput Controller Input, and the basic mapper. The Directinput and mapper plugins seem to be functioning normally, as my controller is showing up and I can map it's different functions to the Scarlet Crush controller. However. after setting everything up, the xinput tester says that there are no xinput devices plugged in. No games that use xinput work either. I'm not sure if I did something wrong while setting everything up. I've reinstalled inputmapper 2.0 and reinstalled the scarlet crush plugin to no avail, the virtual controllers still won't show up. I would greatly appreciate any help.

Please Log in or Create an account to join the conversation.

3 years 10 months ago #2 by Wobbles
When mapping, did you add the output devices?

Please Log in or Create an account to join the conversation.

3 years 10 months ago #3 by Eder

Wobbles wrote: When mapping, did you add the output devices?


Yes, the scarlet controllers show up under output devices in input mapper, however xinput tester says no controllers are plugged in. Same with any game I try to test it with.

Please Log in or Create an account to join the conversation.

3 years 10 months ago #4 by Wobbles
Assuming the channels are mapped correctly, it sounds like the scarlet crush drivers didn't properly install when you installed the plugin. Try manually installing the virtual bus from the plugin's folder

Please Log in or Create an account to join the conversation.

3 years 10 months ago #5 by Eder

Wobbles wrote: Assuming the channels are mapped correctly, it sounds like the scarlet crush drivers didn't properly install when you installed the plugin. Try manually installing the virtual bus from the plugin's folder


That appears to have been the issue, everything is working now. Thank you so much!

Please Log in or Create an account to join the conversation.

3 years 10 months ago #6 by olov
have the same problem i tried to manually install it

Please Log in or Create an account to join the conversation.

3 years 10 months ago #7 by Wobbles

olov wrote: have the same problem i tried to manually install it


you created the virtual device in the mapping plugin correct?

Please Log in or Create an account to join the conversation.

3 years 10 months ago #8 by olov
i think
Attachments:

Please Log in or Create an account to join the conversation.

3 years 10 months ago #9 by Wobbles
and no controllers are showing up in xinput?

Please Log in or Create an account to join the conversation.

3 years 10 months ago #10 by olov
no

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum