Site Login

This Months Donations

$545.03
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
SiesMAN01
$2.00
André Philipi da Silva
$2.00
lookingglassties
$2.00
Keanu Allridge
$5.00
Sven Eckelmann
$10.00
Number of donations
25
Highest donation
$500.00
Average donation
$21.92

Plugin won't update

2 years 9 months ago #1 by nicedude
I'm trying to update my "rock band 4 drum set for playstation 4" plugin from 1.0.0.2 to 1.0.0.3 and when I click update it says restart to install and when i close out and re-open it doesn't update. I've also tried restarting my computer and trying and that doesn't help either. Prob me just doing something wrong but I thought I might as well ask because I'm new to all of this.

Please Log in or Create an account to join the conversation.

2 years 9 months ago #2 by Wobbles
could be the plugin.ini is set up wrong so its not installing properly
The following user(s) said Thank You: chido

Please Log in or Create an account to join the conversation.

2 years 9 months ago #3 by Wobbles
Just checked, the ini looks good. you changed the version in the plugin itself correct?

Please Log in or Create an account to join the conversation.

2 years 9 months ago #4 by nicedude
I keep trying to update from im2 and it tells me to restart to install, but when I restart IM it doesnt do anything, it just says Update Available.
Attachments:

Please Log in or Create an account to join the conversation.

2 years 9 months ago - 2 years 9 months ago #5 by John Wick
Having the same issue as well. With the same plugin. Furthermore, my input devices lists 3 of the same device and won't let me reach the remap setting.
Screenshot attached.
Attachments:

Please Log in or Create an account to join the conversation.

2 years 9 months ago #6 by John Wick
Seems the version mismatch is a typo or issue of some sort with the plugin itself. If anyone else is in the same boat as me and not seeing the 'mapping' button or tab in their UI, it's because an additional plugin called 'Basic Mapping' is required. It's located in the 'application plugins' folder for download and install. Once IM2 is restarted and the plugin is enabled, you should gain the ability to view the 'mapping' tab and click the 'mapping' buttons in the UI.

Thanks for the assistance Wobbles!

Please Log in or Create an account to join the conversation.

2 years 9 months ago - 2 years 9 months ago #7 by FourtySeven
Shit, it is my fault. InputMapper website is a little buggy. I have chosen new file to upload and website said that it was successfully uploaded, but I just noticed, that actual version on website is 1.0.0.2, so program says that update is available and each time it downloads the old version. I'm out of town for work till January 25. I will fix it when I get back home.

Plugin shows three devices because there are actually three different HID-devices with same PID and VID in system. You can check it using any other HID-testing program, they all show three devices. I just show every device that windows API provides. If I leave just one device, you will not be able to connect multiple drum kits at the same time (if you have a lot of them for example). Usually, the first listed device works fine, while the other two are just dummies.

Please Log in or Create an account to join the conversation.

2 years 8 months ago #8 by Cody
Having the same issue. I have the pdp drumkit and they arent showing in the input menu.

Please Log in or Create an account to join the conversation.

2 years 8 months ago #9 by FourtySeven

Cody wrote: Having the same issue. I have the pdp drumkit and they arent showing in the input menu.


Hi guys! Sorry for the delay. I finally got home today and have fixed the issue. You all now are able to update the plugin to version 1.0.0.3 via InputMapper 2.0.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum