Site Login

This Months Donations

$92.81
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Dale
$2.00
Lorren Nelson
$2.00
Rain
$2.00
Fahad
$2.00
Carlo
$5.00
Number of donations
17
Highest donation
$50.00
Average donation
$6.00

Function Wait(Wait for release) function does not work twice, is it normal?

1 year 8 months ago - 1 year 8 months ago #1 by Nameless
As I use a translator, my sentences could be uneven.

I'll take an example.

I use the buttons A, B, C, D and 2, 4, 6, 8. And now I have created these macros
Press A → Press C → Press D → Function Wait(Wait for release) → Release A → Release C → Release D → Pause (Number) → Press 4 → Press D → Function Wait(Wait for release) → [Release 4 → Release D]

I made this macro. And I tested it and it did not work properly. Only certain commands worked as shown below.
Press A → Press C → Press D → Function Wait(Wait for release) → Release A → Release C → Release D(# 1 command)
Only the above commands worked.

But when I removed the commands inside the square bracket, the rest worked fine.
Press A → Press C → Press D → Function Wait(Wait for release) → Release A → Release C → Release D → Pause (Number) → Press 4 → Press D → Function Wait(Wait for release)
4D stays pressed after the command is executed successfully.

Removing the second Function Wait command does not work properly.
Press A → Press C → Press D → Function Wait(Wait for release) → Release A → Release C → Release D → Pause (Number) → Press 4 → Press D → Release 4 → Release D
The above statement works like the # 1 command.

Press A → Press C → Press D → Function Wait(Wait for release) → Release A → Release C → Release D → Pause (Number) → Press 4 → Press D
It works until this command. However, using any method does not release 4D later. If you insert a release, it will only work the # 1 command.



Press A → Press C → Press D → Function Wait(Wait for release) → Release A → Release C → Release D → Pause (Number) → Press 4 → Press D → Function Wait(Wait for release) → Release 4 → Release D
I want to make the above command work properly. Help!!.

Please Log in or Create an account to join the conversation.

1 year 8 months ago - 1 year 8 months ago #2 by wirenut48
try adding a wait to the end.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 8 months ago #3 by Nameless

wirenut48 wrote: try adding a wait to the end.

Add Function Wait(Wait for release) to the end?

Press A → Press C → Press D → Function Wait(Wait for release) → Release A → Release C → Release D → Pause (Number) → Press 4 → Press D → Function Wait(Wait for release) → Release 4 → Release D → Function Wait(Wait for release)
This result like # 1 command. And I used alphabets and numbers to illustrate, but this is not keyboard macros.

Please Log in or Create an account to join the conversation.

1 year 8 months ago #4 by wirenut48
That looks like it should work, but if your just using those numbers and buttons as replacements for the actual values, whose to tell. Why all the secrecy on the forums all of a sudden. This is the second post in a row now on which the true use has not been disclosed. That makes it hard to find a solution or a work a round, feel like I'm wasting my time here. Posting the profile would help.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 8 months ago #5 by Nameless

wirenut48 wrote: That looks like it should work, but if your just using those numbers and buttons as replacements for the actual values, whose to tell. Why all the secrecy on the forums all of a sudden. This is the second post in a row now on which the true use has not been disclosed. That makes it hard to find a solution or a work a round, feel like I'm wasting my time here. Posting the profile would help.



The above image is the operation command I want.




Only the above image is recognized.
If you insert a Function Wait and insert another command later, it behaves like a # 1 command.
Attachments:

Please Log in or Create an account to join the conversation.

1 year 8 months ago - 1 year 8 months ago #6 by wirenut48
Looks as though it should work, depends on how you got it mapped. The only way I could test it is for you to attach the file.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 8 months ago #7 by Nameless

wirenut48 wrote: Looks as though it should work, depends on how you got it mapped. The only way I could test it is for you to attach the file.




I attached the file.

For reference, the version I use is 1.6.10.19991.
Attachments:

Please Log in or Create an account to join the conversation.

1 year 8 months ago - 1 year 8 months ago #8 by wirenut48
OK, what's happening there is nothing to trigger the second release. If you replace it with a pause the string will continue.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10
Attachments:
The following user(s) said Thank You: Nameless

Please Log in or Create an account to join the conversation.

1 year 8 months ago #9 by Nameless

wirenut48 wrote: OK, what's happening there is nothing to trigger the second release. If you replace it with a pause the string will continue.


Thanks to you, I solved it.
Thank you very much.

Please Log in or Create an account to join the conversation.

1 year 8 months ago #10 by wirenut48
Your welcome, love solving problems and learn new things myself by doing so.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum