Site Login

This Months Donations

$535.62
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Sven Eckelmann
$10.00
Nick van de Wall
$500.00
making life on the road more fun thnx
Eric Cota
$2.00
Ricardo Nunes
$2.00
Nick
$2.00
Number of donations
21
Highest donation
$500.00
Average donation
$25.41

ERROR: The remote server returned an error

2 months 1 week ago #1 by Yum
So... I did a stupid and force restarted my Windows 10 computer as it was restarting. It was taking and abnormal amount of time, and I got impatient. I don't know why, but it specifically corrupted the config files of many applications (probably ones I were running at the time) e.g. foobar2000: corrupt playlists, layout, general configs; chatty: chat layout/colors, general configs, etc. Fortunately, I just had to reconfigure those apps to the way I liked them. Unfortunately, InputMapper was no exception to the number of apps I had that screwed up. Since then I've been getting this error from IM, and I can't figure out why. I've tried reinstalling IM but no dice.

This is the error I'm getting:
ERROR: The remote server returned an error: (403) Forbidden. (System.Net.WebResponse EndGetResponse(System.IAsyncResult) in System) []
   at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
   at MS.Internal.WpfWebRequestHelper.EndGetResponse(WebRequest request, IAsyncResult ar)
   at System.Windows.Navigation.NavigationService.HandleWebResponse(IAsyncResult ar)
   at System.Windows.Navigation.NavigationService.<>c__DisplayClass106_0.<HandleWebResponseOnRightDispatcher>b__0(Object unused)
   at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
   at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler
plus exclusive mode is unable to work and bluetooth is disabled.

My DS4 controller still works, but I've noticed something odd about it. On multiplayer games it acting as two controllers for one i.e. I'm able to control both player one and player two at the same time with one controller. I'm guessing that's just the problem with exclusive mode not working.

Please Log in or Create an account to join the conversation.

2 months 1 week ago #2 by Wobbles
The following user(s) said Thank You: Yum

Please Log in or Create an account to join the conversation.

2 months 3 days ago #3 by Yum
Ooh... thanks. Huh, so that's odd, I've been using IM for a very long time IIRC it's the first time I've gotten that (still getting) since the time I did the stupid. I still haven't been able to figure out what's going on with exclusive mode (again a new problem since the stupid). I excluded it earlier because I assumed it was related to the 403 thing. I've no idea what's going on.

Warning: Spoiler! [ Click to expand ]

Please Log in or Create an account to join the conversation.

2 months 3 days ago #4 by Wobbles
Its a security thing, the servers we use recently started requiring SSL for all traffic, this has been resolved in 1.7.
If you need exclusive mode, you may need to install HIDGuardian from here: inputmapper.com/downloads/download/5-too...utmapper-hidguardian
The following user(s) said Thank You: Yum

Please Log in or Create an account to join the conversation.

1 month 3 weeks ago #5 by Yum
I don't think I had HIDGuardian installed before, but I also had to follow these steps to get it working: inputmapper.com/forum/general-chit-chat/...all-creators-for-ds4
Which is weird because I vaguely remember having to do this before a long time ago, and I don't think a screwed up Windows shutdown can undo those things. Well... whatever, I finally got it working now, thanks for the help.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum