Site Login

This Months Donations

$1.64
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Gabriel Pena
$2.00
Jon
$10.00
Nikita
$2.00
Gregory McCoy
$2.00
Karl Scahill
$2.00
Number of donations
1
Highest donation
$2.00
Average donation
$2.00

Exclusive mode tool not working

3 years 6 months ago #1 by dt126
Hello:

Exclusive mode used to work fine on this PC and under Win 10. I read through the threads on this issue. I'm now on 1.6.7.28171, which runs its Exclusive Tool as well as tried the download version and manually disabling/enabling. Is there anything else, maybe XBOX tie-in related, that MS has recently installed that could be the issue or any other way to test what application could be blocking exclusive mode?

I did go about 4-5 months between games where I needed a controller. Any help for troubleshooting would be appreciated. Thanks.

-derek

LOG:

10/2/2016 3:03:25 PM> TRACE: Cached login returned: None|Success
10/2/2016 3:03:25 PM> TRACE: Active application changed to C:\Program Files (x86)\DSDCS\InputMapper\InputMapper.exe (InputMapper)
10/2/2016 3:03:28 PM> TRACE: Starting...
10/2/2016 3:03:28 PM> TRACE: Searching for controllers....
10/2/2016 3:03:28 PM> TRACE: Using Exclusive Mode
10/2/2016 3:03:29 PM> TRACE: VBus: VBus started
10/2/2016 3:03:37 PM> TRACE: Device connected 197352|32768|272880954224
10/2/2016 3:03:41 PM> INFO: Exclusive mode tool ran, please power on controller once more.
10/2/2016 3:03:41 PM> TRACE: Device removed 197352|32772|272880954224
10/2/2016 3:03:47 PM> TRACE: Device connected 197352|32768|272880954224
10/2/2016 3:03:48 PM> WARNING: We are still unable to open the device exclusively even after running the exclusive mode tool for Win 10 AU. The issue likely resides in another application open that is trying to access the controller.
10/2/2016 3:03:48 PM> TRACE: D0:27:88:39:1B:54 device start
10/2/2016 3:03:49 PM> TRACE: Found Controller: D0:27:88:39:1B:54 (BT)
10/2/2016 3:03:49 PM> WARNING: Warning: Could not open DS4 D0:27:88:39:1B:54 exclusively. You must quit other applications like Steam, Uplay before connecting a controller using the exclusive mode option.
10/2/2016 3:03:49 PM> TRACE: D0:27:88:39:1B:54 power subsystem octet: 0x05
10/2/2016 3:03:49 PM> TRACE: Device connected 197352|32768|272880954304
10/2/2016 3:03:49 PM> WARNING: We are still unable to open the device exclusively even after running the exclusive mode tool for Win 10 AU. The issue likely resides in another application open that is trying to access the controller.

Please Log in or Create an account to join the conversation.

3 years 6 months ago #2 by Wobbles
The list of what could do it varies and isn't even necessarily alwayse a game. So far the most common are Uplay, TeamSpeak, Origin, Steam BPM, RadionPro, and this is just what I know, there are likely more. What build and version of Win 10 are you on?

Please Log in or Create an account to join the conversation.

3 years 6 months ago #3 by dt126
I am on 1607, Build 14393.222

The PS Button brings up the Xbox recording toolbar now, I don;t remember this happening when I last used Inputmapper extensively, I was wondering if that is now normal behavior or maybe would help figure out what's causing my issue. Out of what you listed, I never had an issue with Steam before, but I've shut it all down for testing now. I've also periodically used Radeonpro, but it isn't running at the moment.

The most "intrusive" program I've installed since I was previously using Inputmapper before was Dragon (the voice recognition software).That hooks into everything but I think I shut down everything related to it while testing this as well.

Thanks.

Please Log in or Create an account to join the conversation.

3 years 6 months ago #4 by wirenut48
I have no luck running exclusive mode, with tool or manually. I don't have any of the known apps running. luckily don't have any games that require it, wish MS would get this fixed though.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

3 years 6 months ago - 3 years 6 months ago #5 by wirenut48
Update, Seems to be working now, keeping fingers crossed. Now if I could get auto launch working, all would be good. Is the file path still case sensitive? I know 1.5 was, it looks like I have all proper caps now though. I notice the trace log shows different caps than what is found in file path in explorer, so I even matched it up to that. Using 1.6.7

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

3 years 6 months ago #6 by Wobbles
Whats the auto profile issue you are having?

Please Log in or Create an account to join the conversation.

3 years 6 months ago #7 by wirenut48
Just stays on default app sensing profile, but just checked and it works on 3 out of the 5 games I have. Have two seperate profiles for one game, neither works, so it's game related. Now need to find what the common denominator is.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

3 years 6 months ago #8 by wirenut48
Rebooted the PC and now exclusive mode is not working again. Can't figure out why some of the games profiles wont auto launch.

Steam games
Perfect Golf- doesn't work
Virtual Pool 4- doesn't
The golf club- does
Flight Sim X- does but on another drive

Non Steam
Stellarium App- does work

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

3 years 6 months ago #9 by Wobbles

wirenut48 wrote: Rebooted the PC and now exclusive mode is not working again. Can't figure out why some of the games profiles wont auto launch.

Steam games
Perfect Golf- doesn't work
Virtual Pool 4- doesn't
The golf club- does
Flight Sim X- does but on another drive

Non Steam
Stellarium App- does work


So this is one reason why I started a new application detection method, though not implemented yet, and a lot of applications do not properly detect because they are wrapped inside another exe. Most Universal Windows apps and Store apps are contined a common ApplicationPresenter.exe or something like that, Uplay/Origin games seem to like to wrap inside a UplayLauncher.exe or something like that.. yada yada yada... The new way that I am working on will not only allow executable selection, but also firing via window title and process title so it should help get those hard to reach apps.

Please Log in or Create an account to join the conversation.

3 years 6 months ago #10 by dt126
Is there any tool you know of which could be used to determine which process(es) are also using the controller (and blocking exclusive mode)? I've had issues with files being locked before and have been able to determine which processes had the lock. Anything similar exist for a resource lock?

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum