Site Login

This Months Donations

$7.80
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Rain
$2.00
Eddie Binda
$5.00
Gabriel Pena
$2.00
Jon
$10.00
Nikita
$2.00
Number of donations
3
Highest donation
$5.00
Average donation
$3.00

HELP! DS4 controller not working with inputmapper/DS4windows!

3 years 5 months ago - 3 years 5 months ago #1 by TayyabKhalid
Recently my xbox 360 wired controller died, so I bought myself a PS4 controller, and I am loving it so far, no need for a stupid adapter to use it via wireless.

Anyway, I tried both DS4Windows and Inputmapper, while DS4Windows recognize my DS4 when I pair it from start, after I turn off it and try to pair, using the "PS button" it will work, but the ID doesn't show up and it keeps connecting and disconnecting and I have to delete the device from Bluetooth and re-add it. Although, it does recognize when I use USB cable. off or not.
As for inputmapper, it works splendidly with USB cable, but when I try to connect it through Bluetooth it gives me error about exclusive mode, and I already tried all sort of things to make it work, like the bat fix (even tried manual), device manager, reinstall, driver missing, and so on, but none of them would work.

So, if it is not much to ask, could someone please help out this noob so he can also join in on the fun by using a DS4?

Thanks! ^^
The topic has been locked.
3 years 5 months ago #2 by Wobbles
The topic has been locked.
3 years 5 months ago #3 by TayyabKhalid
What a nice community this is, no one is helping. Never have I seen such shitty community service.
The topic has been locked.
3 years 5 months ago - 3 years 5 months ago #4 by Wobbles
Well seeing as how you still have not read this inputmapper.com/forum/inputmapper-1-5-su...t-requesting-support what kind of a response were you really expecting when you refuse to give any of the info I need to troubleshoot the issue.
The topic has been locked.
3 years 5 months ago - 3 years 5 months ago #5 by TayyabKhalid
Warning: Spoiler! [ Click to expand ]


Preparing to load DIFxAPI
Running as 64-Bit process
DIFxAPI path: C:\Program Files (x86)\DSDCS\InputMapper\Virtual Bus Driver\DIFxApi\amd64\DIFxAPI.dll
Loaded library: C:\Program Files (x86)\DSDCS\InputMapper\Virtual Bus Driver\DIFxApi\amd64\DIFxAPI.dll
ScpVBus.inf path: C:\Program Files (x86)\DSDCS\InputMapper\Virtual Bus Driver\ScpVBus\ScpVBus.inf
Virtual Bus Created
DIFXAPI_INFO: 0 ENTER: DriverPackageInstallW
DIFXAPI_INFO: 0 Looking for Model Section [SCProductions.NTamd64]...
DIFXAPI_INFO: 0 Installing INF file 'C:\Program Files (x86)\DSDCS\InputMapper\Virtual Bus Driver\ScpVBus\ScpVBus.inf' (Plug and Play).
DIFXAPI_INFO: 0 Looking for Model Section [SCProductions.NTamd64]...
DIFXAPI_INFO: 0 Installing devices with Id "root\ScpVBus" using INF "C:\WINDOWS\System32\DriverStore\FileRepository\scpvbus.inf_amd64_21ca245c0e23d7a5\ScpVBus.inf".
DIFXAPI_INFO: 0 ENTER UpdateDriverForPlugAndPlayDevices...
DIFXAPI_SUCCESS: 0 RETURN UpdateDriverForPlugAndPlayDevices.
DIFXAPI_INFO: 0 Installation was successful.
DIFXAPI_SUCCESS: 0 Install completed
DIFXAPI_INFO: 0 RETURN: DriverPackageInstallW (0x0)

So, what can be my problem. Why is it that the fix won't work or other several other methods I've tried?
My windows version is: Version 1607 (OS Build 14393,693)
The topic has been locked.
3 years 5 months ago #6 by Wobbles
According to that log it is working fine, I dont see any exclusive mode errors
The topic has been locked.
3 years 5 months ago - 3 years 5 months ago #7 by TayyabKhalid
Then why can't I use it with Bluetooth, I get this stupid exclusive error. I WASTED my whole day yesterday trying to figure it out, and what you have to say to that, it's working. I knew I couldn't count on a developer, they are all the same. This is such a waste of time.

Warning: Spoiler! [ Click to expand ]


How about now?
The topic has been locked.
3 years 5 months ago #8 by Wobbles
This is the FIRST time that you FINALLY included a log that had the relevant information IE the actual error. If your time was wasted then it was your own fault for expecting developers to magically fix issues without providing them the information they need.

And you might want to check your additude. This is a free project, I am the only person who works on it, and its the weekend... My life does not revolve around your gaming schedule.

Goodbye.
The topic has been locked.
Powered by Kunena Forum