Site Login

This Months Donations

$535.62
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Sven Eckelmann
$10.00
Nick van de Wall
$500.00
making life on the road more fun thnx
Eric Cota
$2.00
Ricardo Nunes
$2.00
Nick
$2.00
Number of donations
21
Highest donation
$500.00
Average donation
$25.41

Just doesn't work

2 years 8 months ago #1 by Edouard
Hello,

I bought a Ps4 controller and downloaded Ds4Windows to make it work and so it did, very temporarily

Despite being connected to the PC, the controller would not charge, so I reseted it by putting a pin inside that small hole in the back of it, then it appeared to charge

However the day after, when I opened up the software, it showed me again that the batteries were very low, which is bizarre as the controller always remained connected to the PC and its light were turned off when the PC was shut down

Ds4Windows itself also was bugged as whenever I tried to edit the profile, the binding window would appear and it wasn't possible to close it or even actually bind any buttons, it just kept coming back but thats another story

Today I tried using Ds4Windows again and it couldn't not detect my controller at all, my guess is that it's out of batteries, I tried resetting it again but that didn't work

Finally, I installed InputMapper to see if that software would work better, but after trying to use the controller in a game, it just doesn't work at all

Please help

I'm using Windows 10 Enterprise version 1607 (OS build 14393.693)

Input Mapper version 1.6.10.19991

Warning: Spoiler! [ Click to expand ]

Please Log in or Create an account to join the conversation.

2 years 8 months ago #2 by Edouard
A small update

I tried plugging the controller in a phone charger instead of the PC, hoping that it would charge it, it didn't

When I used it for the first time, the light in the back on the controller was a bright blue, in Ds4Windows I set the light to be dimmer and to pulse when charging. When I did the first reset, the light did pulse blue, however, after it died and I wasn't able to charge it anymore, it pulsed yellow instead of blue for some reason

Now it doesn't do anything when connected, however, the very moment I either plug it in the PC, the phone charger or reset it, it glows yellow once

I'm so mad, I didn't want to buy a Ps4 controller but the Ps3 one I had doesn't work anymore since I swapped from Win7 to Win10. I really don't want to return the Ps4 one and buy a Xbox 1 controller, I really hate the feel of the D-pad, buttons and layout of it, other controllers like the logitech F310 look really cheap and inferior to a playstation one and I can't really test them before I buy

Please Log in or Create an account to join the conversation.

2 years 8 months ago - 2 years 8 months ago #3 by Edouard
Hopefully last update

Got some help and someone told me to try a different usb cable and plug it in a different usb port in my computer
At first it just glowed yellow once and didn't pulse but when I opened Ds4Windows, it got detected by the software and now stays lit blue, it works
I"m pessimistic and don't know how long it will last, I really wonder why it screwed up in the first place

I really want to apologize about my problem not being really InputMapper specific but rather about the Ds4 itself, I hope this thread can probably help someone else out with that kind of controller. If I have problems with Ds4Windows software, it's highly likely that I switch to InputMapper since there's pretty much no support at all with Ds4Windows.

Please Log in or Create an account to join the conversation.

2 years 8 months ago #4 by Edouard
Controller is still working but I know it's going to mess up

Yesterday it was at full charge when it worked again and upon closing my PC, it was still at full charge

Now opening it, it's at 60% battery, why is it losing batteries?!, again,

the controller always remained connected to the PC and its light were turned off when the PC was shut down


Please help before I lose the controller again

Please Log in or Create an account to join the conversation.

2 years 8 months ago #5 by Wobbles
Keeping the controller plugged in all the time is not good for batteries. Disconnect the controller when not in use. You also may not be using a full power USB port and or the cable may not be properly rated for the power.

Please Log in or Create an account to join the conversation.

2 years 8 months ago #6 by Edouard
But it's not supposed to run on the batteries but directly from the PC, just like the Ds3 used to, oh well

It's plugged in a regular usb port, I also have usb 3.0 and sata ports

As for the cable, I don't know what brand is the one I'm currently using but the first was a "Insignia 10 ft. Charge-and-Play Micro USB Cable (NS-GPS4CC101-C2)"

Damn, if I really have to plug the controller to play, then unplug and leave charging every time the battery gets low, I'm seriously considering buying a wired controller

Thanks for replying

Please Log in or Create an account to join the conversation.

2 years 8 months ago #7 by Edouard
That's it, I give up, I had enough of this crap

Yesterday, I disconnected the controller, it was at 40% batteries, the lights were turned off, it shouldn't be running at all

Today, I plugged it in, dead, undetected by the computer or any software, same thing I already explained

Now it doesn't do anything when connected, however, the very moment I either plug it in the PC, the phone charger or reset it, it glows yellow once


So to recap:
-the controller always loses batteries even when turned off
-apparently plugging in it a phone charger charges it but I'm not sure what I need to do to make it work and I have no way to know the battery level
-if then I plug it again in the same usb port it will remain undetected
-if I swap the cable or plug it in a different port and run Ds4Windows then it will get detected (if there's batteries, which again I'm not sure how to charge)

Now I have to buy some wired third party controller that will probably feel horrible or break soon after, damn

Please Log in or Create an account to join the conversation.

2 years 8 months ago #8 by Wobbles
Again, it's the cable or USB bus.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum