Site Login

This Months Donations

$28.19
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Rain
$2.00
Stefan Fuller
$5.00
Paul Benson
$2.00
Ken Mahoney
$5.00
CodemasterRob
$2.00
Number of donations
12
Highest donation
$5.00
Average donation
$2.75

Erratic button behaviour, even after buying a new controller

2 years 8 months ago #21 by Wobbles
The exclusive mode workaround to fighting games that want to blanket connect to all devices they can see (shitty game development) was alwayse a very hackish solution made ever more apparent by the fact that our hacks were broken or rendered useless by the dumbest things like DHCP or Cortana.... But there is literally no way for IM to know that this is not working after a controller has already connected as it is a response sent ONLY at the time of connection, so if something happens after this point there is absolutely no way of knowing, and it has nothing to do with FO4, or detecting it or anything like that because IM does not communicate with any games or applications period.

I would recommend following the IM 1.7a development as it is using a filter driver developed by Benjamin that should solve this issue once and for all, but its still in the alpha/beta stages.

Please Log in or Create an account to join the conversation.

2 years 8 months ago #22 by Zealot
I installed IM 1.7 as suggested, and the problem isn't solved, it's 99% the same.
A few interesting things happened though, and that's why I say 99% and not 100%.

First, I can now get the error message regarding exclusivity every time, right from the start as soon as I connect the cable to the controller. This means that my complaint regarding IM not detecting an issue before Fallout 4 starts has definitely been addressed in IM 1.7.

Second, when I enter Fallout 4 only the SHARE button isn't working (maybe the OPTIONS button too, I can't remember if it ever did anything anyway!). This means that I'm getting from the start the behaviour I was getting in 1.6 after I unplugged and replugged the cable into the controller when inside Fallout 4. So at least I'm getting consistency and it saves me from pulling the cable every time I want to play Fallout 4.
Considering that this thread is called "Erratic button behaviour", it's now more of a "Consistently bad button behaviour". :P

Third, I closed all apps and all processes. Some processes restart themselves, and I can't do anything about it, or at least I don't KNOW if I can do anything about it. I even uninstalled my antivirus (ESET), but that just meant it got replaced by Windows Defender.
I tried to dab at closing some services, but at the second attempt Windows relogged me in, and I got all the apps and processes loaded again.

Look, I've been spending lots of hours with this. I bought a second controller just to troubleshoot this issue. I even uninstalled my antivirus, something I reeeeally didn't want to do. And I reformatted my PC a couple of months ago. I cannot explain why IM is unable to gain exclusive control of my controller. I also don't understand why only Fallout 4 behaves problematically when all other games seem to be perfectly fine without exclusive control.
I did everything asked, and everything I could think of. I even offered access to my machine for troubleshooting. I believe it's high time that the burden of proof is no longer on my side but on developers'.
Attachments:

Please Log in or Create an account to join the conversation.

2 years 8 months ago - 2 years 8 months ago #23 by Wobbles
First off, careful; IM has alwayse been a hackish solution and not a guaranteed solution, and if by developers you mean the one and only developer, me, who has to also balance a job that pays my real bills among other non IM responsibilities while still trying to squeeze in a personal life when able.

To the point though, in 1.7a are you also installing HID guardian correct? and you are using the controller wired? At present benjamins driver only works via USB or Song Dongle. Because of the hit and miss nature of exclusive mode with controller I have dropped application level support for it because there are simply too many instance where it completely breaks as in your case. In 1.7 the user is required to implement 3rd party hacks to ensure exclusive mode on their own, IM will now only warn when it fails and not take any action to correct it.

But at this point I would suggest returning the second controller (which im not sure why you bought as we could have troubleshot the issue without that) and use the money to get a Sony wireless adapter. Not only do you get better signal and rand and audio support, but since it is a USB device, HID Guardian works with it which SOLVES exclusive mode access (at least until something else crazy comes along and breaks it).

Please Log in or Create an account to join the conversation.

2 years 8 months ago #24 by Zealot
Well you keep mentioning Benjamin, so I assumed he was also a developer. I was under the impression you use his code in the app, but to me, as a user, that's just a small detail of who is and isn't considered a developer. I know you are the main dev, but I never thought you'd be the only dev. I stand corrected.

As for HID guardian, I just used the express install, since you didn't specify any parameters when you told me to migrate to 1.7. But running the installer again and clicking Modify I can confirm that there's already a tick on HID guardian.

Getting a wireless solution isn't something that I desire, since I can touch my case with my pinky finger while holding the mouse. I also wouldn't be having any low battery issues with a USB cable connection. But if that's the only solution I guess I don't have any choice...

For the record, I'm buying this item: www.amazon.co.uk/Sony-PlayStation-DualSh...aptor/dp/B01KHFIO82/
If this isn't the same dongle you're talking about, please let me know ASAP. If this dongle isn't fully compatible with the original DS4, and only the new version, please let me know as well.

As for me getting the second controller, I honestly think it's a case of someone talking before thinking things through. The buttons weren't working, I wasn't playing any other game with the controller, IM wasn't giving a notification of exclusivity issues all the time, I definitely needed the second controller to serve as evidence that the issue was with IM and not the controller. Heck I would even replace the case and motherboard if I could afford it, if there was a suspicion that all my USB ports could be malfunctioning. But I think a second controller served its purpose just right, and something I needed to do.

Please Log in or Create an account to join the conversation.

2 years 8 months ago #25 by Wobbles
I am currently in the process of moving to a new PC so my ability to dig too deep into this is limited, but if you are using USB hidguardian will work with that, no need to buy dongle, I thought u were bt. Benjamin develops drivers and while we use them, he is not affiliated with any tool.

Please Log in or Create an account to join the conversation.

2 years 6 months ago - 2 years 6 months ago #26 by Zealot
Wobbles,
I'm sure you'll be delighted to know that installing 1.7.6317.17167 alpha with the HidGuardian drivers fix finally solved my problem! :D
It might have worked with a different version, but I had to format my PC anyway, and I think the Creator Update is installed already, since my winver is 1703.
If you could remove the virtual keyboard from pressing the trackpad button from being on as default, that would be great.

By the way, JFYI, the OPTIONS and SHARE button swapped behaviour, SHARE doesn't do anything in Fallout 4, with OPTIONS bringing the main menu, and I suspect that's how it's supposed to be.

Good work! :)

P.S.: This is with my original controller, I did return the new DS4 v2 in the nick of time. ;)
P.P.S.: IM still says that it couldn't get exclusive mode to work though... If this is something you might be interested in, I'll submit a debug file.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum