Site Login

This Months Donations

$535.62
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Sven Eckelmann
$10.00
Nick van de Wall
$500.00
making life on the road more fun thnx
Eric Cota
$2.00
Ricardo Nunes
$2.00
Nick
$2.00
Number of donations
21
Highest donation
$500.00
Average donation
$25.41

How to use 1.7 download?

2 years 3 months ago #1 by Gerg
Hi, my DS4 has stopped working again after Windows 10 updated and want to try 1.7 to see if it fixes it.

It did work when bought IM and used HIDguardian but is broken again.

It detects controller and enables profile fine but fails to get Executive mode since Windows updated.

Do i just copy files over current IM install or make separate folder and install etc?

Ive tried removing and reinstalling IM 1.6x and HIDguardian but no joy.

Thx for look, Greg.

Please Log in or Create an account to join the conversation.

2 years 2 months ago - 2 years 2 months ago #2 by relsig
I'm on the most recent version of windows and inputmapper 1.6 with exclusive mode working using HIDguardian, so I would focus on getting that working before you try out the 1.7 pre-release but if you're dead set on the pre-release the information you need is here:

inputmapper.com/downloads/category/13-inputmapper-pre-release

to install the vigembus driver you'll need to run devcon.exe in an elevated command prompt. To get devcon.exe you'll need to install the windows SDK or WDK and then place a reference to the exe in your path.

you most likely won't receive any support while using the pre-release software so if you choose to use it before it's released you're mostly on your own.

Please Log in or Create an account to join the conversation.

2 years 2 months ago #3 by Gerg
Hey thanks for reply.

I didnt give many details on OP but can get exec mode working when controller is wired.

Its only when trying to use bluetooth that it fails to get exec mode.

I tried fresh installing Windows 10 and it worked for a little while before failing again.

I though it was Steam causing the issue as i was using DS4 on BT without IM but even after fresh install it only worked for a while before failing to get exec again, even when steam has never launched after a reboot etc.

I think it could poss be an issue with a Windows update thats moving the hardware id randomly after reboots or something.

Please Log in or Create an account to join the conversation.

2 years 2 months ago - 2 years 2 months ago #4 by relsig
That's not very strange, honestly. Inputmapper uses the same device id for both BT and USB. Here's a clean application log (trace filter) showing both types of connection:

Warning: Spoiler! [ Click to expand ]


With certain programs running I can't get exclusive mode with USB (steam). With others I can't get it over BT (origin). At this point a rogue controller grabbing program is probably your best bet but we should try to rule out problems with the program itself as well. If you look at the developer's sticky post about how to request support it'll give you an idea of the information we'd need.

in the meantime, check around and make sure you don't have anything that tries to have low level controller support (discord, teamspeak, skype, steam, origin, etc. etc.) and run inputmapper in administrator mode if you aren't (I think it may by default). You might also try removing the controller from windows' bluetooth interface and resyncing it.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum