Site Login

This Months Donations

$551.19
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Karl Scahill
$2.00
Frederick J Hogsett
$5.00
SiesMAN01
$2.00
André Philipi da Silva
$2.00
lookingglassties
$2.00
Number of donations
27
Highest donation
$500.00
Average donation
$20.61

DS4 having issues connecting (write errors, erratic flashing, etc)

2 years 2 months ago - 2 years 2 months ago #1 by Benie
I just installed InputMapper 1 (latest stable version) and plugged in my PS4 controller (via its USB cable). I noticed the controller's light is flashing erratically (two seconds of not flashing, then two flashes and repeats).
Plus I'm getting read/write errors, latency issues, and the controller continuously disconnecting and attempting to reconnect when trying to use it in a game.
I tried pulling the USB out of a 3.0 port and into a 2.0, and the same issue is happening.

I have Windows 7 Home x64 SP1, not this Windows 10 Anniversary Update. Is there a Windows 7 build that will work? The download section doesn't state what Windows version it supports. Now it's just spitting out constant errors about "unable to open the device exclusively". Unless the thing somehow is sensing I have a PS4, I have nothing else trying to use the application.
Tried to do a restart of my computer, and now it's not even trying to detect my controller. I try to re-enable it, and I'm just getting constant errors to the point it gives up.

Please, someone help.

Warning: Spoiler! [ Click to expand ]


I'm trying to downgrade to version 1.5.31 instead of the latest 1.6.10. No longer seeing the Windows 10 errors, so clearly this is for Windows 7. Still seeing read errors from time to time, though I think it might be a short in the USB cable. I also learned the "erratic flashing" is perfectly normal. I've used this program in the past, but it's been so long that I forgot a lot about it.

Please Log in or Create an account to join the conversation.

2 years 2 months ago #2 by wirenut48
The flashing is the default heartbeat mode. The errors you can ignore, and exclusive mode is not needed for most games.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

2 years 2 months ago - 2 years 2 months ago #3 by Benie
Unchecking 'Use Exclusive Mode' in the Settings (latest version) still gives the same errors. I tried restarting the program. I tried a restart of my computer. Getting the same Win 10 AU errors.

Please Log in or Create an account to join the conversation.

2 years 2 months ago - 2 years 2 months ago #4 by wirenut48
It will function just fine without being in exclusive mode. It is not needed unless you have a game with poor controller support, that allows input from all devices simultaneously. Exclusive mood has been a nightmare to get working as there is so many things that can cause conflicts.

PS believe that setting option is broken.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

2 years 2 months ago #5 by Benie
I don't think you saw my response. I'm getting conflicts even with it off. Please read it.

Please Log in or Create an account to join the conversation.

2 years 2 months ago #6 by wirenut48
edited my post setting is broken, just ignore the warning messages.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

2 years 2 months ago - 2 years 2 months ago #7 by Benie
I don't think you understand the situation fully. If these warning messages weren't affecting the connectivity of the controller, yes I would ignore them. Sadly, it is affecting it. I cannot use the controller in games, because it's continuously dropping the connection.
I believe I had explained this in the OP. I also posted the error log I'm seeing when it happens.

Additionally when it happens, the controller in InputMapper keeps appearing and disappearing, and I even see this in Devices and Printers (of it having a yellow exclamation mark when it happens).

If you feel the Settings tab is not working, then how do I fully disable Exclusive Mode? I'm trying to use it in Shared Mode but it goes back to Exclusive Mode (and the errors/disconnecting and reconnecting thing).

Please Log in or Create an account to join the conversation.

2 years 2 months ago #8 by wirenut48
OK got it now, that problem has nothing to do with Input Mapper. IM does not control the connection of the DS4 to the PC. Possibly the cable since you mentioned you tried different usb ports.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

2 years 2 months ago - 2 years 2 months ago #9 by Benie
What do you mean it "doesn't control the connection"? It does, indirectly. When I installed for the first time, it prompted me to install the files to make the enumerator work.

Also, I don't see how you say it's not IM. These are the same exact errors people are getting when using Windows 10 AU (but in Windows 7). This leads me to believe I'm using a Windows 10 only version.
Please direct me to the latest version that uses Windows 7.
I doubt it's an issue with the USB cable. All I read was something about IM doesn't support USB 3.0, only 2.0.

Please Log in or Create an account to join the conversation.

2 years 2 months ago #10 by wirenut48
The controller has to be connected to the PC first even without IM running for IM to use it. It has to show up in the device manager as a wireless controller even connected usb, with no errors. That's what got me so confused is all the talk of all the IM errors when they weren't even the problem.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum