Site Login

This Months Donations

$1.64
of $500.00 goal
Server, CDN, Network, Licensing
Development Budget
Developers Beer Fund
Recent:
Gabriel Pena
$2.00
Jon
$10.00
Nikita
$2.00
Frederick J Hogsett
$5.00
Karl Scahill
$2.00
Number of donations
1
Highest donation
$2.00
Average donation
$2.00

Can't get exclusive mode to work on bluetooth DS4

1 year 10 months ago #1 by RGV9
Hello,
I realize this has been brought up a thousand times, but I've tried everything on the forum with no result.
I've been using Inputmapper for about a year, and despite a few issues I've been able to get it running properly and exclusive mode was working fine. Recently I updated Windows 10 to the fall creators update and since then it's been just damn near impossible to get exclusive mode to work. I've checked other posts on the forum with people who had the same problem and I've followed several instructions but the problem persists.
I'm running Windows 10 version 1709 OS build 16299.125. Inputmapper version 1.6.10.19991.
Before the update when I wasn't having issues with exclusive mode, I got it to work using the exclusive mode tool from the downloads section. I realize it's an outdated tool and that it's been replaced by Hidguardian but I tried using Hidguardian and it wouldn't work for me. I never really understood why it wouldn't work but what I have noticed is that in the device manager under system devices, Hidguardian virtual device wouldn't appear on my machine even after having uninstalled/reinstalled/rebooted etc. I don't know why that may be, I am using a rather budget device in a Asus Transformer book T100TA which is technically a tablet that has a keyboard in laptop fashion, so maybe there's compatibility issues or it's not supported, but even so that never stopped me from being able to use inputmapper and get exclusive mode to work.
I've removed the DS4 (version 1) from bluetooth devices in Windows settings, reconnected it, uninstalled/reinstalled Inputmapper, uninstalled/reinstalled Hidguardian, tried using exclusive mode tool, followed wirenut's instructions about modifying affected devices values in the registry, but nothing happens. It just won't work and I'm running out of options.

Please Log in or Create an account to join the conversation.

1 year 10 months ago #2 by wirenut48
First you may want to update to win10 version 1803 so you won't have to go through this again. Turn in a support ticket it's automated system will collect what info is needed to properly troubleshoot. We could be going on here for days gathering info and testing.

Asus STRIX X299-E GAMING MB, i7-7820X 3.6/4.5GHz 8-Core, 32GB Corsair Dominator Platinum (CMD16GX4M2B2400C10), NVIDIA TITAN X (Pascal), Samsung 970 Pro 1TB M.2-NVMe w/Western Digital 2TB (WD2000F9YZ), Samsung 65Q9FN QLED, HTC Vive, 850w PS, W10

Please Log in or Create an account to join the conversation.

1 year 10 months ago #3 by RGV9
Done. Updated windows and turned in a support ticket. Thank you for replying. I hope this comes to a solution soon.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum